Changes from older worldKit

Changes from older worldKit
If you are a current user of worldKit, there are a few changes you should be aware of. worldKit is always designed to be as backwards compatible as possible, but in certain cases it's unavoidable.

To determine the your version of worldKit, press "v" and the number will be displayed. If nothing happens, then you can assume it's pre-2.0 :).

Version 3.2, February 16, 2007

zoomifyViewer.swf is no longer required for zoomify integration. And the zoomifynav config option is no longer supported.

Version 3.1, December 29, 2006

Flash Player 8 is now required.

Version 2.0, March 28, 2005

worldKit to Javascript communication has changed, and this version is not compatible with past implementations. With these changes, javascript communication is now supported on more platforms and browsers; and it should be clearer to implement.

February 3, 2005

swflayer now requires an "id" attribute.

January 27, 2005

Interaction in Input Mode has changed slightly. Typing "i" will toggle Input Mode on or off. Previously, holding "i" enabled Input Mode, and releasing "i" left Input Mode.

January 5, 2005

The recommended namespace for geotags in RSS is now "geo", changed from "icbm" (http://postneo.com/icbm/). The "icbm" tag is still supported, and your feeds will work without change.

The size of points, text, and photos is now accurate. Due to a bug, these sizes were previously skewed. So, if you update worldKit, you may need to make adjustments to the size parameters in config.xml.

If you were a beta user of the Zoomify features, the config option to specify the Zoomify install directory is now <zoomifydir>. <dayimg> will no longer work.

If you were a beta user of the Annotation features, longitude is now passed in vairable "long", rather than "lon".